Email latency due to Sendgrid issue

Incident Report for Braze, Inc.

Resolved

Twilio SendGrid has confirmed that it understands the root cause. They have mitigated that and are confident that this issue will not recur. Their engineers are working toward a long-term fix.

Please refer to SendGrid's Statuspage for additional details: https://status.sendgrid.com/incidents/6fj45kvpw8n3
Posted Apr 23, 2025 - 19:14 EDT

Monitoring

Our internal monitoring shows that latency has returned to normal levels as of ~6:30 pm ET.

Emails previously delayed have been processed, and no customers have queued messages. No messages were lost.

Twilio Sendgrid confirmed to Braze at 6:42 ET that this is what they are expecting. We will continue to monitor this to ensure the issue does not recur until we have more details from Twilio.
Posted Apr 23, 2025 - 18:44 EDT

Identified

Braze has identified an issue impacting email latency for customers utilising Sendgrid as an Email Service Provider (ESP).

Sendgrid has updated their Statuspage, communicating the issue here: https://status.sendgrid.com/incidents/6fj45kvpw8n3. Braze is actively monitoring the impact of the issue and working with Sendgrid to resolve.
Posted Apr 23, 2025 - 18:09 EDT
This incident affected: Global Messaging Channels (Email).